Hello Fellow Traders.
I feel ashamed to say that I have been lurking in the background, soaking it all up and feeling pretty much like I had nothing to contribute. It was all being said better and faster by other people and all I could do is hang on.

So this is my attempt to give back and help all the Newbie’s and maybe even some Old Timers by posting the MT4 Chart management Tips and Tricks  in an attachment following below. I also share what have been for me some hard won insights concerning good trading practices. 

It has occurred to me that this may not be the proper Thread to post this on, but as I read the various posts here on TMS, the best forum on FF, I came to believe that this will be a welcome addition. There have been some unnecessary repetitive questions regarding some very basic chart and platform management questions by some new and not so new struggling traders. These, I hope are addressed and put to rest in this document.

While this is directed mostly at beginners, I guarantee that even some seasoned pros will gain some insights here. 
First, I feel compelled to give you my personal feelings about Indicators and their usage. 

Indicators are highly addictive. There are literally hundreds of free Custom Indicators available for MetaTrader with more being created by well meaning super smart Programmers every day. They show you in retrospect what could have been and what you should have done. When exploring them, the quest for the “Holy Grail”, namely the perfect cocktail of more and more Indicators becomes ever more addictive. While this can even be fun, it is also very elusive, resulting in a never ending merry go round of “If I just add this last one, I think this will be the final one, and it will be all I ever need”.

The fact is that the market is moved by mass psychology, which in itself moves constantly... It will exhibit certain repetitive patterns which can be exploited via technical analysis by using a limited number (by that I mean VERY few) Indicators. Any more than that are redundant, repetitive or contradictory and will lead to paralysis by analysis.

That is why if you look at the charts of Professional Traders, you know, the ones that are down several thousand dollars just on the Spread after entering, you invariably will find their charts uncluttered and devoid of extraneous crap.

For most of us who have limited experience and are untrained in Big Bank Trading Floor Market Dynamics, one of these indicators, and in my opinion the best, is the Traders Dynamic Index. It is a hybrid based on some very reliable proven indicators. (See post 7074)
It was developed by Dean Malone some years ago and is freely available. THANK YOU DEAN! 

I have known of him for years, followed him both in paid and free trade rooms but was unable to emulate his success, mostly because he trades the 15 min and the 5 min charts at blinding speeds.

But then, finally, Big E! THANK YOU ERIC! You created Trading Made Simple for all of us who needed a straightforward approach to trading! You gave us a system with Higher Timeframes, Price Action, along with the TDI, on clean charts that are easily interpreted. You therefore gave us a trading methodology using Charts that are untouched by the need to sell and profit from additional “Secret” discoveries. (No offence to those who are in business and need to do so to survive). On afterthought, yea, offence for misleading us!

If you look at the original thread, misnamed “Craig Harris Stochastic Method” and then the new thread “Trading Made Simple” or the latest sub-tread addition of “Indicators for Trading Made Simple”, you will find that the underlying theme revolves around simplifying and de- cluttering the charts while making it easier to interpret price action with the TDI.

There are some incredibly talented Programmers, Traders and Contributors that have come together and have given unselfishly to those of us less smart or skilled, but I hope nevertheless just as determined to succeed.

I will not attempt to name them because I know that I will forget someone, but you know who you are, WE ALL KNOW WHO YOU ARE, AND I FOR ONE THANK YOU!

And that my friend, is it in a nutshell so far…. It may take you months or years to also come to these conclusions, but IMHO I know you will. Hopefully sooner than later. I wish you luck.

Again, a last word of advice: Don’t clutter up your charts with unnecessary junk just because any new knowledge you have learned below allows you to do so.

MT4 TRICKS & TIPS 
Please read the entire document first! Use at your own Risk, I make no representations or give any guarantees that all or any of these shortcuts work, as your software or platform may differ from mine.
MetaTrader4: Use of the mouse and mouse-wheel, and keyboard shortcuts
Scrolling the chart 

· Turn off Auto Scroll then hold down the left mouse button and drag the mouse in the main chart area, to scroll left/right. Or you can also simply roll the mouse-wheel down/up, or use the left/right arrow keys, to likewise scroll the chart view left/right.
· To scroll a whole screen at a time, use Page Up (scroll left) and Page Down (scroll right).
· To reposition to the leftmost bar on the chart, press Home.
· To reposition to the most recent (rightmost) bar, press End.
· To step forward one bar at a time, press F12.
· To step backward one bar at a time, press Shift-F12.
· Scrolling a chart beyond the leftmost bar will add historical bars to the beginning of the chart, until no more are available from MT4's historical database.
Moving directly to a certain date/time—
to re-position immediately to a certain date, press Enter, then type in the date in the form DD.MM.YY and press Enter again. Leading zeros can be omitted (e.g. to move to 4 July 2005, type 4.7.5). To re-position to a certain date/time, use the format HH:MM or DD.MM.YY HH:MM (e.g. to position to 8:07am TODAY on a 1-min chart, simply type 8:7).
Vertical zoom and re-scale—
you can re-scale the chart vertically by moving the mouse into the vertical axis area at the right of the screen, and then dragging downwards (with the left button held down) to compress the chart bars, or dragging upwards to expand them.
Double click to reset the chart to its original scale.
Sometimes after news or a large spike the chart height limits the normal movement of the price action vertically. You can adjust the candles by rescaling them vertically as above. If this puts the chart to high or to low across your screen, you can right click on the chart > Properties > Common > select Scale fix > Ok. Now drag the chart anywhere you want it by holding the left mouse button down. 

Horizontal zoom and re-scale—
similarly, you can adjust the width of the price bars by moving the mouse into the horizontal axis area at the bottom of the screen, and then dragging right (zoom in) or left (zoom out). Or simply use the "+" and "–" keys to achieve this. I have all the toolbars in a row above the chart. You can do so by clicking on to the left of each toolbar and dragging them to the top lining them up one after the other.

Indicators 
Double-click on or near indicators with the left mouse button, to call up the setup windows, from which its properties (parameters, colors, etc) can be changed.
If the screen is cluttered with overlapping indicators and/or objects, making it too difficult to select the desired indicator, press Ctrl-I or Right Click on some free space to call up the Indicators dialog window listing all indicators on the chart. Double click (or click the Edit button, or Alt-E) on the indicator to edit its properties (parameters, colors, etc), or click the Delete button (or Alt-D) to remove it from the chart.
Data Window     I drag it on the chart and make it as small as possible. It is always on top and any data at any point the cursor hits is instantly available. 
Objects 

I find it very helpful to have a confirmation window appear every time I create an Object in which I then can adjust the properties for colors, line type selection, thickness or other property settings. To do that click on Tools > Options > Objects and select the first two boxes > OK. This comes in very handy if you decide against using what you have selected or you just wanted to quickly look at it since you can simply cancel the action.
Double-click on or near an object (line studies, texts or arrows) and a white dot appears. Once selected, you can move an object by left clicking on it and dragging it to the desired destination. Right-click on a selected object to open its context menu.
If the screen is cluttered with overlapping indicators and/or objects, making it too difficult to select the desired object(s), press Ctrl-B to call up the Objects dialog window. Left click the check boxes on/off to select/deselect relevant object(s). Double click (or click the Edit button, or Alt-E) on an object to edit its properties (parameters, colors, etc), or click the Delete button (or Alt-D) to remove it from the chart. To quickly delete a whole block of objects, repeatedly press Alt-D or hold it down (careful, they disappear rather quickly!) Sometimes you may want to clean up your chart and remove all Objects that have cluttered up your charts. The safest way to delete Objects probably is to select the first, and then look as you scroll down to the bottom at the various Objects listed. Hold down the Shift key and then select the last one of the Objects you want deleted. This will select all Objects in between, and then click on Delete.
Remember that this will not delete any indicators only the Object that the indicators are programmed to generate or that you have created. This can be a substantial number of objects after a while. ON THE NEXT TICK ALL INDICATORS PROGRAMMED TO DO SO WILL GENERATE NEW OBJECTS related to them.
Alternatively, from the chart window, press Backspace repeatedly to delete the most recently added object(s) on a last-added-first-removed basis (useful if you want to quickly check out a Fibo or regression channel, then remove it).
Create Parallel Trendlines
to duplicate a parallel trend line, select the line, after the white dot appears, push Control then put your curser over the white dot and left click, wait for the line to unselect itself,(maybe move it just slightly) then Hold and Drag the new duplicate trend line to where you want it to go. You can do this as many times as you want. This also works on Andrews Pitchfork’s if you want to duplicate a parallel fork.
information bubble).
Crosshair mode, and ruler tool
Click the mouse-wheel to switch cursor to the "crosshair" mode.
This can also be achieved by pressing Ctrl-F, or selecting the crosshair icon from the toolbar. The crosshairs also display vertical (price) and horizontal (date/time) co-ordinates at the right and bottom of the chart. 
Simply left-click to exit crosshair mode.

While in crosshair mode, hold down the left mouse button and drag the mouse to obtain a ruler-type tool that measures vertical (number of pips) and horizontal (number of bars) from the center of the crosshairs. The tool displays counters in the form "A/B/C" where A is the number of bars right or left of the crosshair, B is the number of pips from crosshair to cursor, and C is the price at the cursor. You may want to ignore the last digit if you are with a 5 digit broker.

I find this feature extremely useful for measuring the number of pips between any two points, thus again: 
1) move the mouse to the point you want to measure from (the "anchor" point); 
2) click the mouse-wheel to enter crosshair mode; 
3) then hold down the left button and move the mouse to any number of destination points, to see the number of pips between the anchor point and the current mouse destination.
This saves having to calculate this distance manually, as the difference between two prices. Pretty cool!
You can also use this to count the number of price bars between any two dates/times.
Reference and anchor points

Near the upper right corner of your chart there is a dark colored (or white) arrow. Drag it left or right with the mouse to set the location for the last (most current) bar on the chart (i.e. set the amount of empty "space" at the right of the chart). Also make sure Chart Shift is checked under Properties
Templates
After you have arranged you chart to you liking, you should save it as a Template.

Go to Templates on your Toolbar > Save Template > Assign a name to your new template> OK. Do this after every change to your chart if you want to preserve you changes.

Profiles
If you have multiple charts on you desktop, you can save the entire setup under File > Profiles > Save as > Name> Ok.

Deleting and Recovering a Chart

You can of course delete any chart by clicking on the Red X. You have the option to recover that deleted chart by selecting the following: Tools > Options > Charts > Select= Save deleted charts to reopen > OK. Now you can recover recently deleted chart by going to File > Open deleted > Click on the chart you want to get back. It should appear on your monitor. This comes in handy if you have accidentally deleted a chart.

List of hotkeys
There are many other useful hotkeys. Here is a comprehensive list: 

Left arrow — scroll chart to the left; 
Right arrow — scroll chart to the right; 
Up arrow — quickly scroll chart to the left or (if the scale is defined), scroll chart upwards; 
Down arrow — quickly scroll chart to the right or (if the scale is defined), scroll chart downwards; 

Numpad 5 — restores chart vertical scale to its original default. If the scale was defined, this returns the chart back to its visible range;

Page Up — scroll a whole screen to the left;
Page Down — scroll a whole screen to the left;
Home — move the chart to the start point (first bar);
End — move the chart to the end point (last, i.e. most current) bar;
"—" — zoom out (there are 6 levels of zoom available);
"+" — zoom in;

Delete — delete all selected objects;
Backspace — delete most recently added objects, on a last-added-first-removed basis;
Enter — open/close the fast navigation window;
Esc — close any dialog window;
F1 — open the on line help "User guide";
F2 — open the "History Center" window;
F3 — open the "Global Variables" window;
F4 — open MetaEditor;
F5 — switch to the next profile;
Shift+F5 — switch to the previous profile;
F6 — call the "Tester" dialog window for testing the expert attached to the chart window;
F7 — call the properties dialog window of the expert attached to their chart window, in order to change its settings;
F8 — call the chart setup dialog window, allowing basic chart parameters, colors, etc to be changed;
F9 — call the "New Order" window, allowing the entry of market, limit, stop orders;
F10 — open the "Popup prices" window;
F11 — enable/disable full screen mode;
F12 — scroll the chart one bar to the left;
Shift+F12 — scroll the chart one bar to the right;
Alt+1 — display the chart as OHLC bars;
Alt+2 — display the chart as OHLC candlesticks;
Alt+3 — display the chart as a line (closing prices only);
Alt+A — copy all test/optimization results onto the clipboard;
Alt+W — call the chart management window;
Alt+F4 — exit the program;
Ctrl+A — arrange all indicator window heights by default;
Ctrl+B — call the "Objects List" dialog window;
Ctrl+C or Ctrl+Insert — copy selected item to the clipboard;
Ctrl+D — open/close the "Data Window";
Ctrl+E — enable/disable the attached expert advisor;
Ctrl+F — switch to "Crosshair" mode;
Ctrl+G — show/hide the vertical/horizontal grid;
Ctrl+H — show/hide the OHLC line;
Ctrl+I — call the "Indicators List" dialog window;
Ctrl+L — show/hide volume data on the main chart;
Ctrl+M — open/close the "Market Watch" window;
Ctrl+N — open/close the "Navigator" window;
Ctrl+O — open the "Setup" window;
Ctrl+P — print the chart;
Ctrl+R — open/close the "Tester" window;
Ctrl+S — save the chart prices (OHLCV) in a file having extensions: "CSV", "PRN" or "HTM";
Ctrl+T — open/close the "Terminal" window;
Ctrl+W or Ctrl+F4 — close the chart window that's currently in focus;
Ctrl+Y— show/hide date (period) separators;
Ctrl+Z or Alt+Backspace — undo object deletions in the reverse order they occurred;
Ctrl+F6 — switch to the next chart window;
Ctrl+F9 — open the "Terminal — Trade" window and switch the focus into it, allowing trading operations to be entered via the keyboard. 


Attaching Indicators to indicators outside of the main price chart 
You can attach moving averages and other indicators to indicators on other than the main chart. For example, if you want to use a moving average to smooth RSI, do the following: 

1) Create a lower window with RSI in the normal manner.
2) Open the navigator window (press Ctrl-N).
3) Click on the "Indicators" heading in the Navigator window, if necessary, to expand it.
4) Move the mouse to the "Moving Average" item, then (holding down the left button); drag it (a rectangle appears under the arrow cursor) into the RSI window.
5) In the ensuing dialog box, got to the "Apply to" drop down, and set this to "First indicator's data". This will cause the MA to be attached to the first indicator in this window, i.e. the RSI.
6) Adjust other parameters as desired, and press Enter.

I have put multiple Indicators and Custom indicators in the same indicator panel in order to save space by just simply dragging a new indicator into the same window. Be aware that some indicators might interfere with each other but most are fine. You are of course compromising the visual aspect and might end up with a jumble of lines that are undecipherable.
Sorting and arraigning your most used Indicators

If you are like most of us you will accumulate a huge number of Custom indicators over time. I tried to dump a bunch of them at one time and got into a huge mess and had to reload the entire platform along with all indicators I had dumped. It seems some basic indicators pull from other indicators that are not even loaded, I think, not sure.
So in order to avoid scrolling through all those indicators, I put whatever I need from the Navigator into Favorites section of the Custom Indicator section. The way to do that is to right click on the item under the Navigator listing and select ‘Add to Favorites”. The Item should show up in Favorites. Now anytime you click on Navigator your favorites will pop up. Select Common at the bottom to go back to your original Navigator listing.
Adding Custom-defined Indicators to MT4 
One of the most powerful MT4 features is that it has a comprehensive but friendly programming language that allows custom-defined indicators, scripts and expert advisors to be written. Here's how to import an already written indicator into MT4's charting facility:
Here is how to Import Custom Indicators: 

BTW I find it easier to maneuver those files by changing “View” to a “List”.
Import the Indicator from whatever source and save to your Desktop or Download File
Then I go to Start > My computer > Local disk (C :) > Program Files > The name of your Broker/Platform > Experts >Indicators, then drag the indicator to a free space anywhere in the listings. It should appear at the end of the listings at first, but when you reopen the list at some time in the future it will have arranged itself alphabetically with the rest of the indicators. 
Sometime you already have the indicator in which case a window pops up asking you if you want to overwrite the existing indicator. You may or may not want to do that. 

Please go to any web resource that has the source code (mq4 file) for the indicator. Note that a Custom Indicator consists of two files, A Metaquotes Language 4 File and an EXE4 File. I recommend that you import the MQ4 file when you can, as this gives you access to the programming code which will allow you or some one else to modify and adapt the indie to your needs. 
If you want to make some minimal changes to the code, (BE CAREFUL WHAT YOU WISH FOR! ALLWAYS KEEP AN ORIGINAL COPY!) Go to the Meta Editor click on Indicators. After the list populates select your indicator and make your changes such as colors, line thicknesses or alert .wav names, then press compile. Hopefully, the message "0 error(s), 0 warning(s)" will appear, indicating a "clean compile", i.e. that you or the programmer wrote the source code correctly, without syntax errors. Press Esc to close the dialog box and reboot.
This will save you from changing parameters in the pop up box every time you load the indie. I find that many indicators do not keep your changes and reset themselves to the original coded settings after changing timeframes or rebooting. I find the above helpful. Please also note that unlike Custom indicators, the Standard Indies that come with the platform always keep the last change you made, even when you reload them on to another chart.

Note that the following are stored in the these folders: 
Experts/EA’s: c:\program files>Your broker/Platform>experts
Scripts: c:\program files >Your broker/Platform>experts>scripts
Custom indicators: c:\program files >Your broker/Platform>experts>indicators.  
Do yourself a favor and create some shortcuts on your desktop for all of the above! That way you can drag and drop anything new into the shortcut.
Following are some handy resources and refinements that I found helpful. Including some Programs that are free and make a difference:
CrossHair by Richard Janowicz THANK YOU RICHARD!
This is a great little program that let’s you put a Crosshair on anything like a picture or a screenshot. Put it in your lower Tool Tray, use it when you need it and click on it to go back to your regular curser.

Trading Assistant
I believe that MT4 is relatively simple, free, reasonably solid platform with good support and many resources. I also believe that the functionality favors the broker who after all bought it. Some of the functions such as the order entry and order management system and working with the Terminal are strictly Stone Age compared to some other Platforms. That may be by design to favor the broker, kind of like changing dealers, using multiple decks and shuffling the cards every 3 minutes in Las Vegas. 
I know how Eric feels about Ea’s and I am in no way shape and form advocating for an fully automated Ea in this forum, but I sure would love to see someone come up with a Trading Assistant/Dashboard which would feature single click buttons on the chart for entries and exits, drag lines for stops and take profits and a break even function along with options for various types of trailing stops or crossover stops, which would all be tradable from the chart as detailed below. I believe that the FXCM Trading Station which is not MT4 has some of those functions. Their charting system leaves a lot to be desired unless you want to pay for a charting package. 

My trading buddy was in a trade the other day that lasted for 17 4Hr candles. His Exit /Take profit criteria was a cross of the TDI. After 280 pips he was finally wore out having to monitor the trade, and therefore manually closed the trade based more on mental fatigue than anything else.
 I would therefore love at a minimum to see a “Close Trade” engine that would monitor all trades and allow the big runs to run after a manual entry without having to monitor every open and close. It should have the following options:

Close the trade upon TDI cross, hook (by degree?) or flattening. 
Work with any other Ea/Trademanager on the chart such as the QuickTrailing as described below or maybe incorporate those features as described above and below.
 I believe that this would also solidify the trading approach or TMS methodology and keep from having kneejerk reactions due to fatigue and distractions. I sure hope someone will take pity on us and come up with such a system.  Please?
Until such a Trading Assistant is available, I use the Quick Trailing EA strictly as a Chart or Trade management tool. It lets me drag SL and TP levels and it has a break even function. I have made some presets for them. It is flawed and I am not sure that any of the other functions work.
I keep it on the chart, and drag the lines for TP and SL after I enter a trade. It has made life somewhat easier and saved my bacon many times by letting me manage my trades very quickly. 
Topmost Clock   Is always on top and gives you a time stamp on your screen shots. I call it up when I need it.

Cloning the TDI, I just saw this. See post 7074 by The 7 Thank you! I quote:
For those who like to use the TDI indi on a non Mt4 platform. Use these settings:

1. Create RSI in a new window. Set the parameters to 13 and close, and the color to None, so that it doesn't show.

2. Drag the MA indy into the same window as the RSI. Set the values to 2, simple, close, color = Green, and most importantly, Apply to = Previous Indicator's Data

3. Drag the MA indy into the same window as the RSI. Set the values to 7, simple, close, color = Red, and once again, Apply to = Previous Indicator's Data

This will get you very close to the Tdi settings..
Snagit:
 Let’s you take screenshots, annotate those shots and most importantly scroll text and print it out, like on those stupid little indicator input windows that need to continuously scrolled down to show input parameters. I like to print those out and manually keep track of various options. Before Snagit I, I used to print and clip and paste many pages to get a paper overview of what I needed to do. Now I can just scan it and print it. I believe the first 30 days are free. Well worth it IMHO.
 As far as just taking a screenshot if you do not want to bother with Snagit, you can always just right click on the chart and select “Take Picture”. If you have charts with black background, right click go to Properties and change background to white. Careful! Put your sunglasses on first. Then print them.
Game changers
#SR_AlertSystem  Indicator (Brought to my attention by Aussiefx written by Steve Fleming Thank you) and

Audacity: Records voice files.

I monitor 8 pairs at any given time across 4 computers wit 2 monitors each. Trading the 4 hr chart. I like to be at my computer when things are moving, especially when I am in a trade.

It is very confusing for me to listen to any number of “expert.wav” dings or other sounds, since I have to then find the source which can be difficult if there is no popup. After a while they all become meaningless 
How much better would it be if the alert where individual and distinctive for each Purpose and each Pair? How great would it be if you can set an alert level and have it tell you in a human voice “Euro Dollar”? or “Heads Up, or wake up D**P S**T”? We all want to be there when the price action intensifies and our entry criteria are met, or our trade is in jeopardy. Here is how you do it:
To customize the alert notification for the #SR_AlertSystem which consists of an upper and a lower horizontal line that when they get hit, you must first create a sound alert that will trigger at selectable intervals (default 10seconds). To do this, do the following:
Import a free program called Audacity. It is pretty simple and lets you create a .wav file.
For instance, I made a .wav file recording of me saying EURO DOLLAR then went to File > Export as .Wav >C:Drive >Programs >Broker/platform >Sounds > save as EU to the Sound file.
If you double click on any sound file in this program, all the sounds should play. Mine play in iTunes. You may have to experiment with the volume level when you record, since you do not want it to be overwhelming if you use the same speakers to talk on Skype for instance. 

I then go to My Meta Editor>Indicators>#SR_AlertSystem code where I then change the name in the code from expert.wav to EU.wav >compile (you should get 0 Errors 0Warnings …hopefully)>File> Save as #EU_SR-AlertSystem in File name in Indicator file>save.
This will save a duplicate indicator which will call up your customized sound file near the top of your navigator indicator listing. Do not forget to Re-boot the platform.
Now go to Navigator>#EU_SR_AlertSystem and drag it on the chart and you should see one line above and one line below the current price. Double-Click the lines and drag as desired if the price is above or below any of the lines you should hear the sweet sound of your voice saying EuroDollar.

I have done this on all the pairs I monitor and I have to tell you it has changed my life.

I keep my channel pretty tight so I get alerts as the price starts moving. It is one thing to visually see some pairs moving, but it is another thing to have multiple voice alerts go off indicating that the USD is gaining against various currencies. This does not mean that I jump in willynilly, I still follow the TMS entry criteria. I am just a lot more aware of price action and upcoming opportunities especially if I am in trade. Try one pair first to make sure you like to work with the lines before you do all your pairs.
At a minimum this allows you to create a custom or distinctive alert for any Indie that allows you to change the sound .wav file in the code or in the input window. The new sound file can be for all your pairs or for just a specific function on a given pair.
An appeal to all programmers out there, please provide us with the option to change Sound alerts. THANK YOU!

You will have to find your own level of comfort by dragging the lines. It will be very hard to miss any alerts now. If you need to rig up the alert to a vibrator on your chair to notice it, kill yourself.
Please note that there is a negative aspect to all this and that is that you can not change pairs without deleting the Indicator from the chart and the lines from the Objects on that chart. As the price changes to a new pair, the new price will obviously be above or below the old lines and sound off.

The following is for Newbie’s only and probably does not apply to anyone else. (
Trading Psychology.
As you can see from the above, I am not shy about advocating for what I believe in. (Hence all the exclamation marks)
Nothing however comes close to what I am going to tell you next.

I believe that when they say that Trading is 95% psychology and the other 5% are in your head, that this is a gross understatement.

I read or tried to read a number of books on the subject, but nothing comes close to reading ‘Trading in the Zone “by Mark Douglas. I have consequently bought his video program and nothing has ever hit me as hard and spoken to me like those programs. There are some free ones out there if you search for them. 
I will make a few short points to convince you that all your efforts will be for naught if you do not conquer the psychological aspect of trading. 
I absolutely believe that until one can trade without fear, it is impossible, I’ll say it again, ABSOFRIGGENLUTELY IMPOSSIBLE TO BECOME A “CONSISTENTLY PROFITABLE TRADER!

Take my word for it when I tell you that I have been around the block more than a few times. As a matter of fact I have been around so many times that I have often wondered why the cops did not stop me, and accuse me of casing some joint. But I have to tell you that this has been the hardest, most frustrating thing I have ever done! Intelligence (not that I have it in overabundance), hard work, diligence, being previously successful etc. have absolutely nothing to do with being a consistent winner in this business. As a matter of fact all that may work against you. Most successes in life come from being able to effectively communicate and reaching consensus. I think we all know that this skill, however advanced, has no bearing here. 
Anybody can be in a winning trade with a mouse click. It really takes no skill at all. Is it any wonder that we feel utterly betrayed when we have spend all that money and all that time to learn the business? Done everything humanely possible to analyze a trade and then find ourselves stopped out? Time after time?
Well here is what I have learned, and continue to learn from Mark Douglas that I believe has made a difference for me. It has allowed me to a large extend to overcome those emotions that limit me. The hard fact is that most really successful traders have been in the abyss and have managed to climb out. Ssome have just stared into it. But all have yielded to the markets demands. No one has ever “Beat” the market. They may have beat other traders, but never the market.
The Five Fundamental Truths

1. Anything can happen. (Nobody knows what is going to happen. (Deal with it!)

2. You do not need to know what is going to happen next in order to make money.

3. There is a random distribution between wins and losses for any given set of variables that define an EDGE. (Most people believe that big time traders have nerves of steel. That is not true. I am not saying here that there may not be some traders with nerves of steel, but generally they do not. What they do have is an unshakable belief in probabilities and their Edge.)
4. An Edge is nothing more than an indication of higher probabilities of one thing happening over another. (Well guess what? Your edge is the TMS/Big E system! If you trade it over and over, with ridged rules and a small risk, even on a demo, until you have proven to yourself that you can do this over and over in your sleep, you will be able to trade without fear. Because the probabilities are in your favor, you will have found the key to success. This of course is easier said than done, but that is what it is going to take.)
5. Every moment in the market is unique. (Think about it! For the market to be exactly the same as in any previous instance, it would have to have the exact same traders doing the exact same thing again. This is a physical impossibility!)
Therefore and herewith you must master and believe the above, so you can say this:
I Am a Consistent Winner Because:

1. I objectively identify my edges.

2. I predefine my risk of every trade.

3. I completely accept the risk or I am willing to let go of the trade. (This in my experience is a big problem. Especially after you ramp up the position size. If you have gained a number of pips and Dollars with small trades and you have now gained the confidence to trade at your maximum risk, it is very easy to loose all that and more if that trade goes against you. So the tendency is to not accept your loss until the pain of loosing one more Dollar overtakes all your other fears and becomes the deciding factor to close the trade.)
4. I act on my edges without reservation or hesitation.

5. I pay myself as the market makes money available to me. (Scale out?)
6. I continually monitor my susceptibility for making errors.

7. I understand the absolute necessity of these principles of consistent success and, therefore, I never violate them.
If you can get to the point where you can accept your losses with the same emotional balance as your wins, you have arrived. No jumping off a cliff when you lose. It is a good thing! Because you need the losses out of your way to get to that overwhelming number of wins that are sure to come, since you have probabilities and your edge on your side. 
I hope you are not planning to be the only trader in the world without losses. Remember, it is not unusual to have 5 or 6 losses in a row, even when you have a 65% or above win ratio. Also remember that Flat is also a position (possibly the oldest position?) Also, no dancing in the street when you win! Last but not least, do yourself another favor and do not discuss Forex with anybody outside the business. Their uninformed biases will only influence you negatively.
So, there it is. It took me some time to do this, but I learned from it and even enjoyed it.
Use it, hopefully print it out or toss it, it is your choice. I hope I have contributed in a positive way to a community of traders that have given me everything I know about Forex, and whose generosity has never ceased to amaze me.
Thank you Big E and Thank you all!
FXArcher
Disclaimer: The info above was gleaned from various sources (whom I have credited when they where known to me) and from my own experience and research. I have no interest in, or receive any compensation from anyone for anything related here and take no responsibility for direct or indirect damages resulting from application of anything suggested here. Proceed at your own risk.  Warning: I believe that the info presented above is IMHO descriptive but not complete. There will always be newer, more complete and different info evolving. I have tried to do my best to give you some of the things that I have learned and find important. On a personal note: English is my second language and I did not type or ever send an e-mail until about 4 years ago. So I can not get caught up here in long discussions and question and answer sessions. I am limited and I barely have the time to trade and advance my own goals. SO PLEASE: Try not to argue about what is or is not necessary, I think all and more is necessary.  If you want to add to this, great, have at it. If you do not understand something, read it again. If you still do not understand it, Google it. If all fails ask your mom.
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